top of page

October Challenge

Public·10 members
Kirill Dmitriev
Kirill Dmitriev

Os X Mountain Lion Installer App: Where to Find It and How to Use It


As mentioned before, we generally recommend keeping up to date with the latest version of OS X supported by a Mac, which for most machines is OS X Mavericks. You can build a USB installer for Mavericks




Os X Mountain Lion Installer App



Technically, you can also re-download the OS X Lion installer this way too, though it would be hard to imagine a scenario where a user would want Lion over OS X Mountain Lion, let alone OS X Mavericks.


Thanks for this. I first used the leopard installer dvd to do a time machine restore back to Mountain Lion because I had bought a new SSD. I was VERY annoyed at Apple to let me get all the way through it (6 hours with computer going to sleep every 10 minutes) just to get a Kernel error at bootup.


That is most likely not true. The same was reported about Lion, but with a few modifications to the installer script in OsInstall.mpkg, pass 32bit kernal flag in the com.apple.boot.plist and wallah, Lion installs on a core duo like a charm. And no supported machine needed either. So perhaps since Lion runs fine on a 32bit Core Duo MacBook Pro, Mountain Lion is capable as well. It is more likely that a script somewhere in the install process keeps it from installing or recognizing the hardware as an installable host.


I installed it this way. As yet, cannot return to Lion. When i tried to create a bootable USB drive Lion, installer said the version was too new. So not possible to downgrade, or upgrade as it called it.


Apple ended support for OS X Mountain Lion in August 2016, but it remains available for purchase at the Apple Store. Make a bootable flash installer of OS X or macOS if you have a more recent version.


Mac OS X 10. 6 Snow Leopard was released in 2009 and introduced the Mac App Store. Apple used to sell Snow Leopard for $19.99, but Apple no longer offers it. You can find downloadable copies of Snow Leopard and Leopard on the Internet Archive and the reviews on the Internet Archive pages have tips on how to create USB installers from the downloads.


I started by installing El Capitan because that was all I had. The El Capitan installer is on an external USB drive that is partitioned. When I boot to it using either the Option key, the C key, or the Command R keys, the El Capitan installer is recognized. I installed El Capitan, created a Mountain Lion installer on a different partition on the same external USB drive, and erased El Capitan from the internal hard drive. When I boot to the USB, the Mountain Lion installer is not recognized. The El Capitan installer is recognized fine. Why aren't both offered in Startup Manager at boot time? When I had El Capitan installed, both partitions were recognized fine when I plugged in the USB drive. Both were mounted and appeared on the desktop. So I know the problem is not the USB, or 2.0 versus 3.0, or the recovery partition because I've erased the drive and the recovery partition no longer exists. How do I get the Mountain Lion installer to be recognized at boot?


I discovered what the problem was. When I did a Get Info on the El Capitan installer the boot flag was set. It was not set on the Mountain Lion installer. I tried to find a way to set the boot flag and ran across the bless utility. However, it was needlessly complex. So opened the contents of the .app file and found the InstallESD.dmg file. I used Disk Utility to restore this to a blank USB drive. This allowed me to boot to that USB drive, erase the internal hard drive, and install Mountain Lion.


When I had Mountain Lion working fine, I used Disk Utility to restore that same DMG file to the Mountain Lion partition on the external USB drive that also houses the El Capitan installer. All went well and when I booted the MBP holding down the Option key, I got four bootable drives: The main internal, the recovery partition, and both the El Capitan and Mountain Lion installers.


This was pretty much my fault as I think I just copied the Mountain Lion installer .app file to that USB partition instead of actually restoring the DMG file to it. Too many things going on at one time and I missed doing that.


Oh, and two more items. When I start the OS X installer from the external USB drive, I am given three options on where to install TO - OS X El Capitan installer, OS X Mountain Lion installer, and Macintosh-HD. So the Mountain Lion installer partition is recognized but not as an installer to boot from. Even though when I plugged in the USB when El Capitan was installed it showed Mountain Lion as an installer.


The installer will only work if the computer has a version of OS X installed that is prior to Mountain Lion. The installer will not install if you have El Capitan running. It will complain when you try to use it. Also, the model ID is incorrect. Apple did not make a 17" MBP with a Retina screen. The last 17" MBP was made in 2011. It did not have a Retina screen.


I booted to a Linux Mint LiveUSB installer and used Gparted to remove all of the partitions. (Had to do the nomodeset on the grub line.) When I booted to the external USB drive, all I got was the El Capitan installer so I guess I must have made a mistake when I created the Mountain Lion installer. Strange because when OS X is installed, it recognizes it as OS X Mountain Lion installer. Looks like I'm stuck with installing El Capitan. Too bad. At the moment, I don't see anything else I can do.


1. Right-click (or Control-click) the installer and choose Show Package Contents from the contextual pop-up. A new Finder browser window opens, showing the normally hidden material inside the installer bundle.


10. Wait. It will take some time for the drive to be written. Once it's done, eject it, label it clearly, and either use it to install Mountain Lion on a newly formatted hard drive or if you've already upgraded through the normal installer, put it away for a rainy day.


This requires that you have both the El Capitan installer as well as the Mountain Lion installer on your computer (at the paths indicated above, adjust the paths in the command if necessary) and that you have an HFS+ volume with the name 'Untitled' mounted (adjust the name in the command if necessary).


You need to make a bootable installer because the ML installer itself won't run under El Capitan. Trying to, you get a message that the copy of "Install OS X" is too old to be opened on this version of OS X. There are many instructions on how create a bootable Mountain Lion installer on a computer running Mountain Lion, a Mavericks installer on a Mavericks system up to an El Capitan installer under El Capitan. There are also instructions on how to create a bootable Mavericks or Yosemite installer under El Capitan. But I have not found any instructions of how to create a bootable Mountain Lion installer under El Capitan.


Instructions to create a bootable Mountain Lion installer (on a computer running Mountain Lion) usually use the Restore feature in Disk Utility to 'restore' the bootable image inside the installer (InstallESD.dmg) to a USB stick (where 'restore' means cloning the disk image to the USB stick and making it bootable). These instructions cannot be followed to the letter anymore since Disk Utility has changed significantly in El Capitan but there still is a restore feature. Unfortunately the result doesn't appear to be bootable.


Instructions to create a bootable El Capitan (or Mavericks or Yosemite) installer on a computer running El Capitan all seem to rely on a small (command line) executable called createinstallmedia that is part of the OS X Install application (/Contents/Resources), even the GUI options like Disk Maker X seem to rely on it. The command is as follows:


Replacing both occurrences 'El\ Capitan' with 'Mountain\ Lion' gives the expected message that createinstallmedia is not found inside the Mountain Lion installer (because it didn't exist back then when the installer was created). The trick is to replace only the second occurrence, ie, use the createinstallmedia executable from the El Capitan installer.


If you pasted the command I posted above into the Terminal (if necessary adjusting the location of the El Capitan installer), the term 'Mountain Lion' should never show up as a response as it isn't called in the command.


I've just tried it on my computer again and I get the same message as you (though I can create an El Capitan bootable installer, meaning the problem is really the Mountain Lion installer). I even re-downloaded the Mountain Lion installer. I remember vaguely that earlier this year, Apple had a couple of issues with expired certificates and that it was recommended/required to re-download the OS X installers and possibly other apps. I know I did so and the time stamps on the installers on my computer also show this.


About

Stay motivated by connecting with your community during the ...

Members

bottom of page